Support Tools (logo)

DIAGNOSTIC.readme file (February 2007)

The DIAGNOSTICS.readme document describes the requirements of Online Diagnostics for the HP-UX 11i v3 (11.31) February 2007 release.


Overview

OE media contains the following support tools:

Note: Starting with the HP-UX 11i v1 Sept 2005 release, the ODE (Offline Diagnostics) / LIFLOAD product is not included in the OE media. However, the product is available on the HP 9000 Offline Diagnostics CD for PA-RISC-based systems. The product is also available at the HP Software Depot for both PA-RISC and Itanium-based systems.

The support tools are all included in the OnlineDiag bundle. This bundle is distributed in the following ways:

The following command lists the various content levels of the depot:

swlist -l <level> -s/<mount_point> OnlineDiag

where <level> 
         = bundle       Bundle level listing
         = product      Product level listing
         = subproduct   Sub-product level listing
         = fileset      File set listing

      <mount_point>     Location where the CD file system is mounted.

      

Installing Online Diagnostics

To install the Online Diagnostics software using the CLI, complete the following steps:

  1. See the Prerequisites at:
    HP Software Depot website
  2. Log in to the system as superuser.
  3. Mount the CD to a location of your choice, as in the following example:
    # mount /dev/dsk/c1t2d0 /tmp/cdrom
  4. Enter the following command at the HP-UX prompt to install the Online Diagnostics software and all the dependencies:
    # swinstall -x autoselect_dependencies=true -x enforce_dependencies=true -s /tmp/cdrom OnlineDiag
  5. Unmount the CD. Enter the following command at the HP-UX prompt to unmount the CD:
    # umount /tmp/cdrom
  6. Enter the following command at the HP-UX prompt to verify whether the Online Diagnostics software is installed properly:
    # swlist | grep OnlineDiag
    If the Online Diagnostics software is installed properly, OnlineDiag and the version number of the software are displayed in the output. If the Online Diagnostics software is not installed properly, you must repeat the installation procedure.

You must load STM after the operating system is installed. The EMS Hardware Monitors are installed automatically when STM is installed.

For the HP-UX 11i v3 February 2007 release, the following apply:


Required and Recommended Patches

None


Loading Patches

You can load the patches, if applicable, in one of the following ways:

Method 1:
Install the entire patch bundle.
Install the entire Hardware Enablement Bundle (HWE) or Quality Pack (QPK) patch bundle for your system.
Advantage: Simple and tested process
Disadvantage: The bundle can be many megabytes in size.

The patch bundles are distributed in the following ways:

Method 2:
Install the individual patches from the bundle.
Install only the required individual patches for your system from the patch bundle.
Advantage: Small number of patches
Disadvantage: Requires knowledge of commands

Method 3:
Install the individual patches from website.
You can also obtain the patches from the HP IT Resource Center (ITRC) at:
http://us.itrc.hp.com/
Note: You must reboot your system after loading a patch from this website.


Known Problem

You cannot access online help on Itanium-based systems.

Cause:
You require a browser to view online help using the cstm, mstm, and xstm interfaces. The default supported browser is Mozilla. If you are using any other browser, you must configure STM for the interfaces.
Note: You do not require a browser to access online help on PA-RISC-based systems.

Action:
To configure the browser for the xstm and mstm interfaces, complete the following steps:

  1. Start xstm by running the following command at the HP-UX prompt:
    # /usr/sbin/xstm
  2. Select the Options->General Options.
  3. Enter the full path of the browser.
  4. Click OK.
To configure the browser for the cstm interface, complete the following steps:
  1. Enter the following command at the cstm prompt:
    cstm>gop
    A list of options is displayed.
  2. Select the appropriate options.
  3. Select the browser of your choice.

For more information on the online help, see the STM Online Help at:
http://www.docs.hp.com/en/diag/stm/sth_summ.htm


Removing Diagnostics

To remove Online Diagnostics from your system, complete the following steps:

  1. Log in to the system as superuser.
  2. Enter the following command at the HP-UX command prompt:
    # swremove OnlineDiag
  3. To verify whether the Online Diagnostics software is removed properly, enter the following command at the HP-UX prompt:
    # swlist | grep OnlineDiag
    If Online Diagnostics is removed properly, OnlineDiag and the version number of the Online Diagnostics software do not appear in the output. If the Online Diagnostics software is not removed properly, you must repeat the removal procedure.

Getting More Information

You can obtain more information on Diagnostics (Support Tools) at the following locations:


Top of Page

/ Diagnostics HOME


URL: http://docs.hp.com/en/onlinedocs/diag/st/str_0702.htm
Last updated: Fri Nov 10 09:19:36 PDT 2006