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Legal Notices 

Copyright Notices. © Copyright 2006 Hewlett-Packard Development Company, L.P. 

The information contained herein is subject to change without notice. The only warranties for HP products 
and services are set forth in the express warranty statements accompanying such products and services. 
Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for 
technical or editorial errors or omissions contained herein. 

Acrobat® is a trademark of Adobe Systems Incorporated. Intel®, Celeron®, Pentium®, and Intel® Xeon™ 
are trademarks or registered trademarks of Intel Corporation or its subsidiaries in the United States and 
other countries. Java™ is a US trademark of Sun Microsystems, Inc. Linux is a U.S. registered trademark of 
Linus Torvalds. Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation. 

Printed in the U.S.A. 

Reproduction, adaptation, or translation of this document without prior written permission is prohibited, 
except as allowed under the copyright laws. 

Related Documents. The HP Server cc3310 User Information Diagnostics and Utilities Resource CD-ROM 
has been provided with your server. It contains a complete documentation set for the server. Included on the 
CD-ROM is the hp Carrier-Grade Server cc3310 Product Guide, which contains in-depth troubleshooting, 
installation, and repair information. 

The CD will autorun when you insert it into an operating Windows workstation, or boot from the CD after a 
hardware reset.  

In addition, the latest versions of all these documents, and any product updates to these documents, are 
posted under the appropriate server at: http://docs.hp.com.
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Introduction 

Telco Alarms Manager (TAM) is a set of telecom server software components designed to manage the alarms 
state of the server and indicate health status via the local Telco Alarm Panel (TAP) as well as remotely via 
dry contact relays. The TAM Service receives alarm requests from multiple entities, such as the Intel Server 
Management (ISM) Local Response Agent (LRA), the Intel Linux Resource Monitor (RM), the SNMP Event 
Agent (for SNMP traps), and other applications which have registered with TAM. 

Additionally, the Telco Alarms Manager delivers several APIs that permit access to the TAP. Application 
developers who wish to manage the alarms state from within their application can do so by using these APIs, 
which bypass the TAM Service management of the state machine. 

 

Configuration Requirements 

The TAM (2.0, rev 1.0) is provided for use on the HP Carrier Grade Server cc3310. 

Required Software Components: 

• Red Hat Advanced Server (AS) 2.1 

• Red Hat Enterprise Linux (RHEL) 3.0 

• Microsoft® Windows® 2000 Advanced Server, SP3 or higher 

• Microsoft Windows 2003 Advanced Server 

Required Software Components: 

• TAM 2.0 

− Activate a hot key combination to enter secure mode quickly. 
− No additional software components required 

• TAMTools 2.01 

− Java™ Runtime Environment (JRE) Version 1.3 
− SNMP Agent Software 

                                                 
1 UCD-SNMP and SunJRE (J2SE) are delivered software components. Other third-party components may require additional 
configuration. 
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Installation 

TAM 2.0 is provided on the HP Server cc3310 User Information Diagnostics and Utility Resource CD.  

To run installation directly from CD: 

Installation can be started from the Welcome page that auto runs when the CD is mounted or inserted. From 
the welcome page, select Management SW. From the drop down Management Software page: 

1. If you are using a Linux OS, select the Install Linux ISM/TAM Driver’s box (at the bottom of the 
page). 

2. If you are using a Windows OS, select ISM\Software\win32\TAM. 

 

Telco Alarms Manager Event Agents 

Overview 

TAM is designed to work with software or modules that register with TAM. This registered software is 
referred to as event agents. These event agents relay information to TAM so that any problems that occur on 
a system are indicated by the LEDs on the alarm panel. A set of TAM event agents is delivered as part of the 
TAM software package. 

PI Event Agent 

ISM’s PI (Platform Instrumentation) Event Agent is installed with ISM on the Resource CD. PI monitors 
and provides information on several baseboard and hardware components. Any exceeded thresholds or alerts 
that it receives are mapped and forwarded to TAM, which illuminates corresponding status LEDs on the 
alarm panel. The following is a summary of some of the hardware components monitored by PI. Please refer 
to ISM documentation for more detailed information. 

• Fan (failure, speed) 

• Memory (single- and multi-bit errors, ECC errors) 

• Processor (thermal trips and internal errors) 

• Temperature (baseboard and processor temperature) 

• Voltage (standby, baseboard, and processors) 

• Power supplies (presence, redundancy, and temperature)  



SNMP Event Agent 

The SNMP Event Agent is installed with TAM. It is delivered as a component of TAMTools. The SNMP 
Event Agent listens for configured SNMP (Simple Network Management Protocol) traps. Any exceeded 
thresholds or alerts that it receives are mapped and forwarded to TAM which illuminates corresponding 
status LEDs on the alarm panel. 

NOTE TAMTools must be running for this feature to be active. You can run TAMTools in the 
background by starting it in the shell with a "tamtools –t" command. TAMTools is an example 
of how the TAM API can be used to operate the Telco alarms. 

System Event Agent 

The System Event Agent is installed with TAM. It is delivered as a component of TAMTools. The System 
Event Agent polls and monitors configured system events. Linux leverages the proc file system and makes 
system information available for configuration as subsystems, resources, and statistics. Any exceeded 
thresholds or alerts that the System Event Agent receives are mapped and forwarded to TAM, which 
illuminates corresponding status LEDs on the alarm panel. 

NOTE TAMTools must be running for this feature to be active. You can run TAMTools in the 
background by starting it in the shell with a "tamtools –t" command. TAMTools is an example 
of how the TAM API can be used to operate the Telco alarms. 

On-Screen Display (OSD) Event Agent 

The OSD (On-Screen Display) Event Agent is installed with TAM. It is delivered as a component of 
TAMTools. The OSD Event Agent is useful as a diagnostic or development tool. It can return the panel’s 
state, send user-generated alarms to the alarm panel, and return event records stored in the alarms 
database, such as the GeneratorID, GeneratorInfo, AlarmID, and Severity.  

 

Configuration 

TAM Model 

In the cc3310 server (firmware-based model), alarm processing is managed via the BMC (Baseboard 
Management Controller).  
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Alarm Models 

TAM supports two models, Most Severe and All Severities. If TAM is running in firmware-based mode, the 
SDR (Sensor Data Record) can be configured to change the alarm model. Please refer to the BMC TAM EPS 
for SDR information. If TAM is running in software-based mode, the alarm model can be configured by 
modifying the tamconfig file and setting ALL_SEVERITIES_MODEL to yes or no. TAM must be restarted 
in order for this change to take effect. 

• Linux: /usr/local/tam/etc/tamconfig 

• Windows: <TAMTargetDirectory>\tamconfig.dat 

• TAMTools: OSD Tab > Options > Alarm Model 

Most Severe Alarm Model—Only the most critical alarm LED is illuminated. For example, if a minor 
alarm is present and a major alarm occurs, the minor alarm data will be retained in the alarm database; 
only the major alarm LED will be illuminated. If the condition that set the minor alarm previously still 
exists when the major alarm is cleared, the minor alarm will once again become illuminated. The Most 
Severe model is the default alarm model. 

All Severities Alarm Model—All alarm LEDs for which alarm data exist will illuminate. This behavior 
facilitates the illumination of multiple LEDs simultaneously.  

Alarm Severities 

Severity modifications are dependent upon the Event Agent’s configuration. The Event Agents analyze 
events from the hardware and software applications, and map the sensor severity to a Telco Alarm severity. 
The Event Agents then make calls to the TAM with the alarm information for alarm table entry and LED 
illumination. Table 1 lists descriptions for each alarm panel LED. In ISM, a noncritical map to a minor TAM 
event, a critical maps to a major TAM event, and nonrecoverable maps to a critical TAM event. 

Table 1. Severity Mapping 

TAM Alarm Panel LEDs Description 

MINOR (MNR) A non-service-affecting condition. Corrective action should be taken in order 
to prevent a more serious fault. 

MAJOR (MJR) A service-affecting condition that requires an urgent action.  

CRITICAL (CRT) A service-affecting condition that requires an immediate action.  

POWER (PWR) Only active for power or voltage events. 

DISK (DSK) Activated during disk activity. 

(NIC) Activated during network activity. 

(ON) Activated when system is powered on. Not activated when system is powered 
off. 
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TAMTools 

NOTE TAMTools must be running for this feature to be active. You can run TAMTools in the 
background by starting it in the shell with a "tamtools –t" command. TAMTools is an example 
of how the TAM API can be used to operate the Telco alarms. 

Overview 

TAMTools is a Java-based stand-alone application that performs various Telco Alarms Manager functions. 
TAMTools is composed of event agents that serve as a conduit to allow different types of events (System, 
SNMP, user-generated) to be mapped and configured to the server's alarm panel LEDs. Each tab in the 
TAMTools application performs one of the event agent’s tasks.  

Configuration File 

An XML-based configuration file is used to store TAMTools configured events. This configuration file resides 
under /usr/local/tam/etc/tamtools as tamtools.xml for Linux installations. This configuration file 
makes deployment and configuration of multiple systems an easier task. tamtools.xml is generated as the 
end-user makes selections in the TAMTools user interface, or the user can create this file from any text 
editor, open it through the interface, or copy it to the TAMTools directory directly. In cases such as non-
graphical OS installations, the TAMTools parses this file to forward events to TAM, therefore making the 
GUI in TAMTools an optional component. Please see Appendix B: TAMTools Schema for schema 
information.  

Opening a Different Configuration File 

To open another configuration file, select File > Open in the TAMTools menu bar. The title bar always 
reflects the current configuration file that is in use with the TAMTools application. 

Saving Configured System Events to a Different Configuration File 

tamtools.xml is the default configuration file for TAMTools. You can save the settings to another file for 
backup, replication to other similar servers, etc. To save the configuration to another filename, select File > 
Save in the TAMTools menu bar. 

System Tab 

The System tab represents the System Event Agent. Some of the objects that are monitored under the 
system event are: disk, CPU, process, network, etc. The System Event Agent gets a current reading for the 
selected object. A threshold can be set to trigger a Telco Alarms Manager LED assertion. The System Event 
Agent stores configuration information in tamtools.xml. This configuration file can be imported or 
exported to additional servers. 

Terminology 

The following terms provide information needed for configuring the System Event Agent (Windows): 
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• Object— An object represents major hardware component(s) such as memory, processors, etc.  

• Counter—The monitored value(s) of an object.  Each object has 1 or more counters.  For example, 
available memory is a counter for the memory object. 

• Instance— Some objects have multiple entities.  For example, the PhysicalDisk object may have one 
instance - c:\ or multiple instances - c:\, d:\, and e : \. 

The following terms provide information needed for configuring the System Event Agent (Linux): 

• Subsystem—A subsystem represents major hardware components, such as memory, processors, etc.  

• Statistic—The monitored value(s) of an object. Each object has 1 or more statistics. For example, 
available memory is a statistic for the memory object. 

• Resource—Some objects have multiple entities. For example, the PhysicalDisk object may have one 
resource – /usr or multiple resources – /,/boot,/home,/usr,/var, etc. 

Configuring System Events 

Select the System tab and select components to monitor. The last reading box will show the latest reading 
according to the polling interval that is set. The polling interval can be changed by selecting Options > 
Configure in the TAMTools menu bar. Set thresholds for minor, major, and/or critical events by selecting 
the conditional operator and entering a value. A value must be entered to clear the event before the 
configuration is accepted. Then select Add. This configuration is saved to the xml file and can be viewed 
immediately in the details window. To remove events, select the System tab and details to view event 
details. Select the event that you wish to remove and then select Remove. This configuration change is 
updated to the xml file and can be viewed immediately in the details window.  
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The SNMP tab represents the SNMP Event Agent. The TAMTools MIB browser allows the user to select 
SNMP entries or TRAP entries and configure a threshold for the entry. The threshold allows for the 
generation of a Telco Alarms Manager LED assertion. The SNMP Event Agent stores configuration 
information in tamtools.xml. This configuration file can be imported or exported to additional servers. 

NOTE Before the TRAP entries will be visible, it is necessary to load a MIB file from Option>Load 
MIBs. 

Terminology 

The following terms provide information needed for configuring the SNMP Event Agent:  

• MIB—MIB stands for Management Information Base. A MIB file defines what parameters or variables 
can be accessed and how they are interpreted. 

• OID—OID stands for object identifiers. The OID is a unique identifier for read-only, read-write, and trap 
information. 

• Trap—A trap is an event sent by the SNMP agent to a SNMP manager. Objects and values may be sent 
with the trap. 

• Variable—(Sometimes called variable binding or trap variable) is the object and value that gets sent 
with a trap PDU message. 

• Browser—A program to walk (traverse) MIB files to display SNMP parameters. 

Configuring SNMP Events 

• Load MIBs—MIBs need to be loaded first before the MIB values can be browsed. Select Options > 
Load MIBs in the TAMTools menu bar to load MIB files. For example: In order to receive SNMP traps 
for network interface card (NIC) events, you must install specific NIC SNMP software from the following 
Intel web site: http://support.intel.com/support/network/adapter/1000/software.htm . 

• Download the Native SNMP software for your operating system and follow the installation and 
configuration instructions that are included in the download package. One of the files in the installation 
package will be a MIB file. This file can be loaded with the Load MIBs function. Traps will not be visible 
until a MIB file is loaded. 

• MIB files that are used by ISM are installed in /usr/share/snmp/mibs. 

• Browse for Traps—Select the SNMP tab. Trap values can be identified by a red dot icon beside them. 
You can expand and collapse the MIB tree quickly by using the Expand and Collapse buttons. Select the 
trap value and go to Options > Configure in the TAMTools menu bar or select Configure. Select the 
variable to monitor and set thresholds for minor, major, and/or critical events by selecting the 
conditional operator and entering a value. A value must be entered to clear the event before the 
configuration is accepted. Then select Save. This configuration is saved to the xml file and can be viewed 
immediately in the details window. If this trap occurs, the selected variable's value is compared with 
threshold settings.  
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• Removing SNMP Events—Select the SNMP tab and select details to view event details. Select the 
event that you wish to remove and then select Remove. This configuration change is updated to the xml 
file and can be viewed immediately in the details window.  

OSD Tab 

TAMTools provides an on-screen display tool that shows the Telco Alarms Manager state and the Telco 
Alarm Panel state. TAM OSD is available for use as a debug or development tool. The OSD Event Agent 
allows you to set and clear LEDs and it lists alarm information for all event records stored in TAM. 

OSD Configuration Options 

Select the OSD tab and go to Options > Configure in the TAMTools menu bar. In the Configure dialog, 
selections are presented for Alarm Persistence and Alarm Model.  

Alarm Persistence—The behavior of the Alarm LEDs through system restarts is configurable on a per 
Event Agent basis. TAM can automatically clear alarms from specific Event Agents upon restart, or the 
alarms can be left for the Event Agent to clear when it determines its health state. Please note that 
changing this setting only affects OSD Event Agent alarm records. 

Alarm Model—Alarm models are discussed on page 8. Changing this setting affects all installed Event 
Agents on the system. 
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Appendix A: Glossary 

This appendix contains important terms used in the preceding chapters.  

Acronym Definition 

API Application Programming Interface 

BMC Baseboard Management Controller 

ISM Intel® Server Management 

J2SE Java 2 Platform, Standard Edition 

JRE Java Runtime Environment 

LRA Local Response Agent 

OSD On-Screen Display 

PDU Protocol Data Units 

PI Platform Instrumentation 

RM Resource Monitor 

SDR Sensor Data Record 

SNMP Simple Network Management Protocol 

TAM Telco Alarms Manager 

TAP Telco Alarm Panel 
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Appendix B: TAMTools Schema 

This appendix contains an example XML tag and schema definition for the Event Agents used in TAMTools. 

<?xml version=”1.0” encoding=”ISO-8859-1”?> 

<tamtools> 

<system> 

<systemId obj = “Disk” 

counter = “Available” 

instance = “/” 

id = “1” 

power = “false” 

clear = “&gt; 800” 

minor = “&lt; 500” 

major = “&lt; 300” 

critical = “&lt; 200”> 

</systemId> 

</system> 

<snmp> 

</snmp> 

</tamtools> 
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